-
Notifications
You must be signed in to change notification settings - Fork 36
Using Github with Eclipse
kalden edited this page Apr 25, 2013
·
2 revisions
The EGit tool enables you to work with an iDynomics Github repository via Eclipse - the IDE used and recommended by those developing iDynomics. Here, we will show how to install EGit and how to download your own fork of your code directly into Eclipse. However, it is recommended that you also refer to the EGit user guides (referenced later). We make the assumption here that you have previously installed Eclipse.
- In a web browser, go to http://eclipse.github.com/
- Click Download EGit from Eclipse.org (top right at time of writing)
- In the section Installing the Latest Release, copy the address of the Main Repository to the clipboard, but don't click it.
- Now open your version of Eclipse. Click Help -> Install New Software. Paste the web address you copied into the Work With box.
- The box will populate with software options. Tick the box for the "Eclipse Git Team Provider" and install all its sub-packages.
- If successful Eclipse should ask to be restarted.
- Set up your credentials (username and email): In Eclipse Click Window -> Preferences -> Team -> Git -> Configuration. We're going to add a new entry. Click New Entry. In the Key, type user.email, with the value being your email address. Add another new entry, with the key user.name, and the value being your name.
EGit has a good manual and tutorial, and thus there is little point repeating that here. The manual can be accessed both within Eclipse and online here.
- You will need to have your own copy of the iDynomics repository, within your own account in Github. Details of how to do this has previously been covered on this wiki here. Follow all the instructions up to and including pressing the Fork button, then do the next steps.
- In Eclipse, from the File menu, choose Import.
- Select Git, then Projects from Git. Press Next.
- On the next screen, we're importing from Github, so choose URI. Press Next.
- In the URI box, insert the web address of your github iDynomics repository (not the master, your forked version). You can get this from your repository page on Github. Make sure you are copying a link that begins with https rather than ssh. Once pasted into eclipse, the rest of the information is completed for you, except your github username and password. Enter these and press Next
- The next screen asks you to choose which branch you want to import. If you are working on a new copy of the iDynomics code, there is only one branch, master. Click Next
- The next screen asks you to choose where you would like to store the local repository. If you are not happy with the default, change it, else just click Next.
- Your forked copy of the code will then be imported into Eclipse. To do this, leave the wizard at the default "Import Existing Projects" and press Next. On the final screen, just press Finish.
- Once you have made changes, you can commit these to your repository and, if you wish, suggest to the developers that we incorporate your changes into our code. Committing changes back to your repository is covered in the EGit user manual and thus is not repeated here. Once you have uploaded your changes, you can perform a Pull Request with your suggested changes as explained in the relevant section of this wiki.