Description
When the subscriber that dispatches a request to Radarr/Sonarr can't figure out which server to use because:
- The request's stored
serverId points at a server that was deleted OR
- There is simply no default server for that 4K/non-4K tier
Then it logs a warning and returns allowing the request to stay APPROVED and then the media proceeds to PROCESSING but nothing is ever sent to either Sonarr/Radarr and is not recoverable because POST /request/:id/retry only accepts request that are marked FAILED. The only recourse is to delete the request and make a new one.
Version
3.4.1
Steps to Reproduce
- Make a request without auto-approve on.
- As admin delete the server that the request was intended for.
- Approve the request.
Screenshots
No response
Logs
Platform
desktop
Database
SQLite (default)
Device
PC
Operating System
Windows 11
Browser
Brave
Additional Context
No response
Search Existing Issues
Code of Conduct
Description
When the subscriber that dispatches a request to Radarr/Sonarr can't figure out which server to use because:
serverIdpoints at a server that was deleted ORThen it logs a warning and returns allowing the request to stay
APPROVEDand then the media proceeds toPROCESSINGbut nothing is ever sent to either Sonarr/Radarr and is not recoverable becausePOST /request/:id/retryonly accepts request that are markedFAILED. The only recourse is to delete the request and make a new one.Version
3.4.1
Steps to Reproduce
Screenshots
No response
Logs
Platform
desktop
Database
SQLite (default)
Device
PC
Operating System
Windows 11
Browser
Brave
Additional Context
No response
Search Existing Issues
Code of Conduct