[As of Kubernetes 1.22, `certificates.k8s.io/v1beta1` is no longer being served](https://kubernetes.io/docs/reference/using-api/deprecation-guide/#certificatesigningrequest-v122). The request-cert container/binary [uses the `v1beta1` API](https://github.com/cockroachdb/k8s/blob/master/request-cert/k8s_certificates.go#L25) and will fail to create a CSR in newer Kubernetes clusters: ``` failed to get certificate: CertificateSigningRequest.Create(%s) failed: the server could not find the requested resource ``` To mitigate this issue, we'll have to upgrade to `certificates.k8s.io/v1` and drop support for Kubernetes < 1.19.
As of Kubernetes 1.22,
certificates.k8s.io/v1beta1is no longer being served.The request-cert container/binary uses the
v1beta1API and will fail to create a CSR in newer Kubernetes clusters:To mitigate this issue, we'll have to upgrade to
certificates.k8s.io/v1and drop support for Kubernetes < 1.19.