Skip to content

request-cert no longer works as of Kubernetes 1.22 #36

Description

@chrisseto

As of Kubernetes 1.22, certificates.k8s.io/v1beta1 is no longer being served.

The request-cert container/binary uses the v1beta1 API and will fail to create a CSR in newer Kubernetes clusters:

failed to get certificate: CertificateSigningRequest.Create(%s) failed: the server could not find the requested resource

To mitigate this issue, we'll have to upgrade to certificates.k8s.io/v1 and drop support for Kubernetes < 1.19.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions