Skip to content

Does open-local support using vg on block devices without partitions? #260

Description

@Fan123-ui

Question

I have created vg1 on my block device/dev/sdb. There is 10T of space on vg1 occupied by other LVs. After adding vg1 to the whitelist, but the created pvc is always pending, prompting “failed to provision volume with StorageClass "open-local-lvm": rpc error: code = Internal desc = CreateVolume: fail to get lv local-b3c76e87-6cff-4b96-a9df-013302b073bd from node node-01: rpc error: code = Internal desc = failed to list LVs: Failed to run cmd: nsenter --mount=/proc/1/ns/mnt --ipc=/proc/1/ns/ipc --net=/proc/1/ns/net --uts=/proc/1/ns/uts lvs --units=b --separator="<:SEP:>" --nosuffix --noheadings -o lv_name,lv_size,lv_uuid,lv_attr,copy_percent,lv_kernel_major,lv_kernel_minor,lv_tags --nameprefixes -a open-local-pool-0/local-b3c76e87-6cff-4b96-a9df-013302b073bd, with out: Volume group "open-local-pool-0" not found.”

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions